日次アーカイブ: 2017年05月19日

タイトルにKUSANAGIと入れているのですが、たぶん普通のLNMP環境にZabbixをインストールしても起きるかと。KUSANAGI環境でもWEBサーバーがNginxではなくApacheだったらこれに該当しないはず。

今までアクセスできていたZabbixサーバにブラウザでアクセスしたら500エラーを吐いてたのでエラーログを見てみたら

2017/05/19 02:12:29 [error] 773#0: *3913 FastCGI sent in stderr: "PHP message: PHP Warning:  require_once(/etc/zabbix/web/maintenance.inc.php): failed to open stream: Permission denied in /usr/share/zabbix/include/classes/core/ZBase.php on line 269
PHP message: PHP Fatal error:  require_once(): Failed opening required '/etc/zabbix/web/maintenance.inc.php' (include_path='.:/usr/local/php7/lib/php') in /usr/share/zabbix/include/classes/core/ZBase.php on line 269" while reading response header from upstream, client: 1**.2**.***.***, server: kan4.example.com, request: "GET / HTTP/2.0", upstream: "fastcgi://127.0.0.1:9000", host: "kan4.example.com"

なんてメッセージが出てたので、あーこりゃZabbixアップデートしたときに権限書き換わっちゃったんだなーと。というわけで対処。

…続きを読む